修订:2025-08-05
Nscd不适用于Web服务,同时与systemd-resolved功能重叠,二选一,不需要在服务器和云控制台放通53端口
以Rocky9为例
sudo dnf install nscd -y
sudo systemctl enable --now nscd
sudo vi /etc/nscd.conf注:–now 是设置开机启动和启动服务
修改
positive-time-to-live hosts 3600 #缓存时间 单位秒 根据情况自行修改 推荐2小时 7200
negative-time-to-live hosts 20 #缓存失败缓存时间 单位秒 推荐设置0sed -i '/^netgroup:[[:space:]]*sss/ s/^/# /' /etc/nsswitch.conf #注释 netgroup 功能
sudo systemctl restart nscd #重启
sudo nscd -i hosts #手动清理缓存卸载Nscd (没啥好说的 全部复制丢进终端)
sudo systemctl stop nscd
sudo systemctl disable nscd
sudo dnf remove -y nscd
sudo rm -f /etc/nscd.conf
sudo rm -rf /var/db/nscd/
rpm -q nscd